VSM 100 SE HV-Signale von ks-vorsignal

From now, the TrainzDepot is in a read-only mode, see our announcement). From now, our new place-to-go, https://www.trainz.de is available.
Since 28.02.2019 personal data (e.g. profile contents, private messagers) has been deleted.
  • Hallo an alle,
    ich möchte dieses Thema aufmachen, da es ja seit dem 17.01.2017 die VSM 100 SE HV-Signale von ks-vorsignal für T:ane unter Build-Version 4.2 auf der DSL gibt.
    Ich möchte das man hier die Möglichkeit hat seine Erfahrung zu diesen Signalen zu schreiben oder auch Fehler zu benennen und auch Hilfe bei Problemen zu geben.
    Ich hoffe das dieses im Sinn aller ist und auch vom Autor ks-vorsignal.


    Lg. Karl-Heinz K.

  • Hallo Karl-Heinz,
    Habe mir die gerade runter geladen und werde die mal Versuchsweise mit einbauen. Bekommst auf alle Fälle ein kurzes Feedback!

  • Die Benutzung ist relativ einfach. Es gibt zwei Varianten der Konfiguration. Entweder man stellt in den Signalen selbst die Fahrstraßen mit Signalbild ein, die man haben will oder man lässt das Signal sich die Fahrstraßen selbst suchen und das Signal zeigt dann dafür ein passendes Signalbild. Bei der letzten Variante kann man z.B. mit den Gleismarkern von DBSig arbeiten, also z.B. Geschwindigkeitsmarker oder Sh1-Marker. Da wurde also erfreulicher Weise ein (begrenzte) Kompatibilität geschaffen.


    Gruß
    wallner


    Nachtrag: Und wichtig, Durchrutschwege am nächsten Signal frei halten, sonst geht das erste Signal nicht auf Fahrt, obwohl die Strecke zum zweiten frei ist. 50m bei 40km/h, 100 bei 60 km/h und 200 bei allem darüber.

  • Bei den Einstellungen läßt sich leider der Alterungszustand nicht einstellen. Ob das so gewollt war/ist?! Aber ansonsten kann ich mich meinem Vorredner nur anschließen.

  • Hallo,


    soweit ich weiß, geht auf der ersten Seite der Einstellungen zur Zeit nur die Auswahl des PZB-Magneten und die Drehung des Signals. Alles andere wird nach und nach implementiert, wenn die passenden Meshes verfügbar sind. Der Upload war meines Wissens erstmal ein Beta-Upload um zu schauen wie die Signale funktionieren. (Sollte es anders sein, bitte ich um Verbesserung).


    Grüße


    Max

  • Hallo.
    genau das ist ja auch ein Punkt warum ich dieses Thema auf gemacht habe, um auch mögliche Fehler auf zu Zeigen in der Hoffnung das Thomas ks-vorsignal hier mit liest.

    Es soll bitte nicht so verstanden werden, das es negativ ist sondern eher positiv und als Rückmeldung gedacht ist.
    Ebenso wenn jemand Probleme hat das man Ihm Hilfe geben kann.


    So ist mir auf gefallen, wenn ich im Editor Zs3 aktiviere wird nur es nur als Zs3-Formsignal angezeigt, gehe ich in den Fahrer-Modus ist das Zs3-Signal komplett verschwunden.


    Lg. Karl-Heinz K.

  • Zs3 wird korrekt angezeigt. Es wird nur dann als Formsignal angezeigt, wenn du einen festen Wert als Geschwindigkeit eingibts. Lässt du das Geschwindigkeitsfeld leer, erscheint Zs3 als elektrischer Anzeiger. Es kommt in der Tat ab und zu vor, dass bestimmte Zusatz-Meshes nicht immer angezeigt werden. Fährst du mit der Kamera aber über das Signal und wieder zurück erscheint das Zs3 Mesh auf einmal. Das scheint eher ein TANE interner Darstellungsfehler zu sein.

  • Mein 1. Test verlief negativ, Signale sind vergleichbar mit DBSig und hat auch fast die gleichen Probleme in TANE


    -teilweise Anzeige falscher Signalbilder,
    -erkennt nur sich selbst,es gibt keine sperrsignale.
    -arbeitet nicht mit IT oder eIT zusammen,(Fehlermeldung).

  • Signale sind vergleichbar mit DBSig und hat auch fast die gleichen Probleme in TANE

    Wenn ich mich recht erinnere hat der Autor, Thomas Mehlberg (ks-vorsignal), mit seinen Signalen so um 2007 oder 2008 begonnen, das war dann doch lange vor T:ANE. Nachdem seine Schöpfungen nun fast schon in Vergessenheit geraten waren, finde ich es ausgesprochen erfreulich, wenn er jetzt wieder aktiv geworden ist, und seine Werke zudem auf die DLS gestellt hat. Vielleicht arbeitet er sich ja auch ins T:ANE-Stellwerk ein. An moralischer Unterstützung wird es sicherlich nicht fehlen, und auch von Praxistests und Zuarbeit im Signalwesen aus der Anwenderschaft ist ja in den letzten Wochen einiges zu lesen gewesen.

  • Signale sind vergleichbar mit DBSig und hat auch fast die gleichen Probleme in TANE

    Nein zwei versch. "Ansätze" im Prinzip. Bei den DBSig warte einfach mal Version 7 ab, dann wird sicher einiges klarer

  • Mein 1. Test verlief negativ, Signale sind vergleichbar mit DBSig und hat auch fast die gleichen Probleme in TANE


    -teilweise Anzeige falscher Signalbilder,
    -erkennt nur sich selbst,es gibt keine sperrsignale.
    -arbeitet nicht mit IT oder eIT zusammen,(Fehlermeldung).

    Hallo Schnackel, ich habe die Signale ziemlich intensiv durchgetestet und die von dir angesprochenen Fehler sind mir dabei nicht aufgefallen. Da an den Signalen aber noch gearbeitet wird, wäre es gut detailliert beschriebene Fehlermeldungen zu kriegen. So könnte man tatsächlich vorhandene Fehler noch ausbügeln.


    • Unter welchen Umständen treten falsche Signalbilder auf? Bitte alle Umstände genau beschreiben.
    • Ja, das Signalsystem erkennt nur sich selbst. Der Übergang zu einem anderen Signalsystem funktioniert genauso wie bei DBSig. Es ist ein Marker zu legen, der das Ende des Signalsystems kennzeichnet. Hierfür kann der TrackEndMarker von DBSig verwandt werden oder der beim VSM System mitgelieferte Signal System Connector
    • Die Signale arbeiten mit IT und ITE zusammen. Ich habe eine Anlage mit ca. 20 IT und ITE auf der die Signale problemlos arbeiten. Ein Tip, um die Signale mit Interlocking Towers zum Laufen zu kriegen, die Signale müssen im IT immer auf "automatic" gestellt sein. Nur dann können die Signalupdateroutinen laufen. Ansonsten werden die Signale vom IT überstimmt, welcher aber nur rot oder grün an das Signal übermittelt aber kein differenziertes Signalbild. Ansonsten wäre es gut, wenn du die Fehlermeldung posten könntest, um zu sehen, was da schief läuft.

    Viele Grüße


    wallner

  • Erst mal danke das ihr hier Hilfe bietet die ich wohl auch brauche.


    @wallner

    Unter welchen Umständen treten falsche Signalbilder auf? Bitte alle Umstände genau beschreiben.

    Der Fehler ist mein Fehler gewesen. Der vom Signal verlangte Durchrutschweg war zur kurz. Das Signal 50m zurückversetzt und es klappt. Den Info fand ich hier bei TD erst vor kurzem. Das war wohl ein Hauptproblem bei mir.
    Nächstes Problem Signalbild
    Ausfahrsignal zeigt Hp2 dahinter folgt weiche 1, die stell ich um also Signal fällt auf Hp0. ok. Weiche zurück gestellt aber signal bleibt auf hp0. :| Vor dem Signal befindet sich weiche 2 mit 2 sperrgleisen. vor den sperrsignalen stehn loks.
    wird weiche 2 nun gestellt zeigt das signal wieder richtig an. Es reagiert aber nie auf weiche 1,wenn ich die hin und herstelle.
    Erst muss ich weiche 2 einmal stellen, dann erst funktioniert es wie es soll.


  • Hallo Schnackel,


    befindest du dich im Driver Modus oder im Editor Modus? Im Editor Modus funktioniert das mit der Anzeige der Signalbilder nicht immer, da ein Signalupdate im Editor nicht bei jeder Aktion ausgelöst wird. Da kannst du also teilweise ein bisschen herumklicken, bis das Signal reagiert.


    Nehmen wir nun an, du befindest dich im Driver Modus. Ferner nehme ich an, dass es sich nicht um im Signal eingegeben Fahrstraßen handelt, sondern um Fahrstraßen, die sich das Signal selbst suchen muss. Dritte und letzte Annahme, deine Züge, welche vor dem Signal stehen, haben sich in der Session noch nicht bewegt.


    Das Problem ist eine bekannte Limitierung der Signalfunktion, welche voraussichtlich auch nicht beseitigt werden wird, da sie Performance bedingt ist. Das ganze hängt mit der Trainz internen Signalupdate-Häufigkeit zusammen. Bei Fahrstraßen, welche sich das Signal selbst suchen muss, braucht das Signal mindestens zwei Update-Durchläufe, um ein passendes Signalbild anzuzeigen. Der erste Durchlauf, dient der Feststellung, ob eine Fahrstraße gebildet werden kann und welche Eigenschaften diese hat. Im zweiten Durchlauf wird dann ein Update des Signalstatus ausgelöst (DetermineUpdatedState) sowie ein Update des Signalbildes durchgeführt (ApplyUpdatedState). Bei im Signal selbst hinterlegten Fahrstraßen braucht man nur einen Durchlauf, nämlich den für Signalstatus (DetermineUpdatedState) und Signalbild (ApplyUpdatedState).


    Das Problem ist, das TANE nicht mehr die Signale jederzeit updated (war in früheren Train-Versionen teilweise anders), sondern ein Update nur auslöst, wenn sich ein Zug auf das Signal zubewegt oder Weichen im Umfeld des Signals gestellt werden. Ein Update wird aber (meist) nicht ausgelöst, wenn ein Zug vor einem Signal steht. In deinem Fall also löst Trainz ein Update aus, wenn du die Weichen umstellst. Mit diesem Update wird die Fahrstraße eingelesen. Da dein Zug aber steht, folgt kein zweites Update und der Signalstatus und das Signalbild ändert sich nicht. Hättest du eine im Signal hinterlegte Fahrstraße benutzt, sollte sich das Signal geändert haben.


    Um das Problem zu entschärfen, wurde im Script eine Prüfung eingebaut, ob vor dem Signal ein Zug steht. Steht ein Zug vor dem Signal erzwingt das Signal alle paar Sekunden (wenn ich mich recht erinnere alle zwei Sekunden) einen Updatedurchlauf. Mit zusätzlichen Updatedurchläufen kann man die Performance in Trainz aber sehr schnell zerstören. Es erschien daher nicht sinnvoll, für jeden abgestellten Wagon, dauernd ein Update des nächsten Signals auszulösen. Daher wird ein Update nur ausgelöst, wenn sich der Zug, der vor dem Signal steht, bereits in der Session bewegt hat.


    Letztendlich gibt es mehrere Möglichkeiten dein Problem zu lösen:

    • Du kannst die Fahrstraße, die du haben willst, manuell im Signal hinterlegen statt mit Track Markern zu arbeiten.
    • Falls du mit Track Markern arbeitest und vor dem Signal ein Zug steht, der sich bereits bewegt hat, gib dem Signal ein paar Sekunden Zeit zu reagieren.
    • Falls du mit Track Markern arbeitest und vor dem Signal ein Zug steht, der sich bisher noch nicht bewegt hat, lass den Zug gegen das Signal anfahren. Das Signal springt dann sofort in den korrekten Zustand.

    Falls das alles nicht hilft, wäre es schön, wenn du deine Situation nochmal und möglichst genau beschreiben könntest.
    Viele Grüße


    wallner

  • @wallner
    vielen dank für Deine Tipps und die ausführliche Erklarung zum Hintergrund. Ich teste es auf jeden Fall weiter,
    ich arbeite bisher mit Fahrstrassen und konfiguriere die Signale den Reitern nach durch , nutze nur Endmarker vor Portalen, den Gleisenden und vor dem Formsig(bpanther) einer Stichstrecke. Vieleicht hab ich ja einfach etwas übersehen bei der Konfiguration. Mir fehlt eine Beispielstrecke zu diesen VSM-Signalen :star: in Tane.

  • Hier mal ein sehr sehr kurzer Überblick über das System:
    VSM 100 SE ist, im Gegensatz vielleicht zu anderen Signalsystemen, ein streng Fahrstraßen orientiertes Signalsystem. Die Grundkonzeption besteht darin, dass man Fahrstraßen anlegen kann und diesen Signalbegriffe zuweist, die dann vom Signal angezeigt werden. Man kann einer Fahrstraße auch mehrere Begriffe zuweisen, damit das Signal anhand von zusätzlichen Randbedingungen (im Moment nur der D-Weg und ob eine Rangierfahrt vor dem Signal steht. Bei Ks-Signalen dann auch bei "Halt erwarten"), seinen Begriff wählt. Es implementiert nur die Signalisierung. Fahrwegesteuerung und Zugbeeinflussung werden von Fremdkomponenten (z.B. PZB-Trigger, LZB-Streckenrechner, ITs etc.) übernommen.


    Hierin besteht wohl auch die größte Kopfnuss, wenn man es einsetzt. Da man im Grunde so denken muss wie bei den IT (modular und fahrstraßenorientiert). Die internen Vorgehensweisen von IT und VSM sind relativ ähnlich (was übrigens zufällig ist, da das Grundkonzept von 2012 stammt), wobei sich VSM technisch an den Fahrstraßenstellwerken orientiert, allerdings um wenige Elemente der Spurplantechnik erweitert. Ein Import der Fahrstraßen aus den IT ist angedacht, um den Konfigurationsaufwand zu minimieren.


    VSM 100 SE ist noch kein fertiges Signalsystem. Es ist im Moment lediglich eine Neuauflage von alten VSM 100 mit neuerer Technik, daher habe ich es nicht vorgestellt. In erster Linie möchte ich es im T:ANE Multiplayer testen, da es, zumindest formal, dafür programmiert wurde. Das ist auch der Grund dafür, wieso es das System nicht für den TS12 gibt.


    Ich will noch vier Ratschläge geben, da ich im Moment keine Zeit habe eine Anleitung zu schreiben:
    - Es ist empfehlenswert, das Signalsystem mit dem VSM 100 SE Rangierfahrtenmonitor (ist eine Regel) zu kombinieren. Dort kann man Züge zu Rangierfahrten machen. Er ist allerdings im augenblick noch nicht ganz fehlerfrei, wie das restliche Signalsystem auch.
    - Die VSM BÜ Marke stellt die Abhängigkeit zu Bahnübergängen her. Damit werden BÜ durch die Signale geschlossen und geöffnet bzw. überwacht.
    - Der VSM Fahrstraßenausschluss schließt sich kreuzende bzw. sich ausschließende Fahrwege aus.
    - Die Signale geben auch Kopfschutz. Darauf sollte man achten, wenn ein Signal mal nicht auf "Fahrt" springt. Es könnte auch daran liegen, dass die Fahrt in ein Gleis verhindert wird, in das gerade jemand von der anderen Seite her einfahren will.


    Alles weitere (z.B. Fernabschaltung, Vorsignalisierung, was ist D-Weg und was haben Zusatzsignale damit zu tun etc.), wenn ich mal etwas Zeit zum formulieren habe.


    Bis dann!

  • Ist es möglich, eine abwärtskompatibilität zu TS12 herzustellen? Würde das System auch gerne nutzen, habe TANE aber noch nicht...

  • Also geht es schon wieder los, das gefordert wird :cursing: !
    Es ist doch klar geschrieben worden das die Signale für T:ane gedacht sind und zweitens noch dran gearbeitet wird Punkt.
    Also lasst bitte erstmal eines fertig werden und dann liegt es am Autor was Er weiter macht.


    Entschuldigt das ich das schreibe, aber bitte last doch mal die Kirche im Dorf oder soll wieder ein Objekterstelle seine von dannen gehen.
    Mir könnte die Hutschnur platzen :cursing:

  • "Ist es möglich" ist zwar keine Forderung, der Rest stimmt aber.
    Kauf Dir einfach T:ANE und alle Probleme mit dem Programm, den Signalen und mit Karl-Heinz sind gelöst.


    Und das Gute: TS 12 geht weiterhin, Du musst es nicht aufgeben für T:ANE:


    Gruß
    Norbert