Trainz fehlerfrei neu installieren (CM funktioniert nicht mehr)

  • Hallo allerseits,


    da meine Festplatte mit der Zeit voll geworden war und der CM schon lange nicht mehr das macht, was er soll, habe ich nun meine zweite neue Festplatte für Trainz und meine persönlichen Dateien partioniert.

    Einige meiner Dateien sind schon auf der neuen Festplatte, allerdings muss ich noch mein TANE und Trainz Simulator 2012 auf dieser Festplatte installieren.

    Ich habe Trainz wegen der Probleme mit dem CM schon oft neu installiert, habe aber immer wieder Probleme mit ihm, darum möchte ich nun alles richtig machen und brauche eure Hilfe.

    Ich weiß, dass dieses Problem schon sehr alt ist, weil ich mich schon sehr lange nicht mehr intensiv damit beschäftigt habe, dieses Problem komplett aus der Welt zu schaffen, darum war ich auch so lange nicht mehr online.

    Eigentlich habe ich nur zwei Theorien, die diese Probleme mit dem CM erklären könnten.

    1.

    Könnte es sein, dass bei meinen Deinstallationen einige Trainz-Dateien nicht gelöscht wurden, nach den Neuinstallationen nun doppelt oder dreifach vorhanden sind und diese Probleme verursachen?

    Wenn ja, wie kann ich feststellen, dass Trainz komplett und restlos deinstalliert wurde?

    2.

    Um den CM nutzen zu können, muss die bzw. müssen die Seriennummern bei Planet Auran eingetragen worden sein.

    Sollte man bei einer Neuinstallation auch die Seriennummern neu eintragen, oder ist das völlig unbedenklich?


    Der CM kann sehr wichtige Objekte nicht mehr herunterladen, zum Beispiel die xBUE-Regel und die dazugehörigen Kontakte, von denen ich nicht denke, dass sie einfach nicht für TANE ausgelegt sind, was ja bei manchen anderen Objekten wieder der Fall ist. Manchmal schlägt das Herunterladen (egal was) auch komplett fehl.

    Außerdem bricht der CM bei großen Streckendownloads nach einiger Zeit das Herunterladen der Abhängigkeiten ab, dieses Problem haben aber bestimmt viele von euch, da der CM einfach manchmal Probleme macht, das vorher erwähnte jedoch ist doch eine Frechheit sondergleichen.

  • dynamit777

    Hat das Label auf T: ANE geändert
  • Eine bereits registrierte Seriennummer brauchst du meines Wissens nicht noch einmal einzutragen. Du siehst ja beim Programmstart irgendwo "Logging into Planet Auran ...". Wenn die Meldung kommt, haben TANE und die Hilfsprogramme Zugriff, und wenn du immerhin einiger Objekte herunterladen kannst, scheint der CM ja Zugriff auf die DLS zu haben.


    Der CM kann sehr wichtige Objekte nicht mehr herunterladen, zum Beispiel die xBUE-Regel und die dazugehörigen Kontakte, von denen ich nicht denke, dass sie einfach nicht für TANE ausgelegt sind, was ja bei manchen anderen Objekten wieder der Fall ist.


    Lässt sich denn die xBUE-Regel im Browser herunterladen und dann als CDP manuell installieren? Funktioniert sie dann? Oder erscheint ein gelbes oder sogar ein rotes Fehlersymbol?

    Eventuell erscheint auch bei "Fehler und Warnungen anzeigen" im Kontext-Menü des CM etwas, was hier weiterhelfen könnte.

  • Leider habe ich mich schon sehr lange nicht mehr damit beschäftigt, darum kann ich momentan nichts genaueres dazu schreiben.

    Wenn ich mich jedoch recht erinnere, wurde oft sogar jeder Downloadversuch im CM von TANE abgebrochen, danach hatten die jeweiligen Objekte aber keine Fehlermeldung, sondern wurden im CM genau so angezeigt, wie auch vor dem Downloadversuch.

    Mein erstes Ziel ist allerdings erstmal die Neuinstallation auf der neuen Festplatte, damit ich dem CM nochmal richtig auf den Zahn fühlen kann.

    Vielleicht funktioniert er ja dann wieder, vielleicht aber auch nicht.

    Höchstwahrscheinlich werde ich dieses Wochenende jedoch nicht mehr dazu kommen.


    Ich bedanke mich aber vielmals für deine Antwort.:)

    Hast du noch einen Tipp, wie ich nach der Deinstallation auf der alten Festplatte überprüfen kann, ob alle Trainz-Dateien Deinstalliert wurden?
    Ich denke nämlich, dass nicht deinstallierte Dateien Störungen verursachen könnten, sicher ist sicher.

  • Moinsen zusammen,

    Ich habe auch des öfteren Neuinstallationen machen müssen, allerdings waren da Bedienfehler meinerseits wohl auch mit im Spiel. Zum einen habe ich nach der Deinstallation den gesammten Ordner gelöscht wo TANE drin war. Zum anderen habe ich TANE und den UserContens auf 2 verschiedenen FP. Zur Installation habe ich auf die Vorgehensweise von TRAINZ 12 zurückgegriffen wonach davor der Rechner komplett runtergefahren und neu gestartet wurde, und auch den Norton habe ich während dessen deaktiviert. Nach Neuinstallation habe ich das Programm gestartet und erst einmal angepaßt, soll heißen Benutzername etc. Die Installation habe ich auf Englisch gemacht und erst nachdem alle Patches und SP´s daruf waren manuell(Nicht im Spiel selber) auf Deutsch umgestell. Ferner habe ich mir auch die Mühe gemacht nach jedem Patch einen Spielstart und auch Rechner Neustart durch zu führen damit Tane alles auch erkennen kann. Bis jetzt hat sich diese(langwierige) Vorgehensweise aber bezahlt gemacht.

    Wenn von den Erfahrenen hier einer dieses mit ließt(lesen möchte) und meint es wäre ein Fehler, möge er bitte etwas dazu schreiben. Es sind meine Erfahrungen, müssen deswegen weil ich zu wenig drin bin auch nicht gerade die besten sein?!

  • Naja, ich mache es vielleicht doch etwas einfacher, aber danke für den Tipp.;)

    Die Ordner von Trainz werde ich aber auf jeden Fall noch nach der Deinstallation löschen, wenn du das so gemacht hast und es funktioniert, dürfte das hoffentlich reichen.

    Außerdem werde ich TS12 auf der einen und TANE auf der anderen Partition installieren.

    Ich kann ja nach jeder Trainz-Installation den PC nochmal neu starten, damit sich alles einpegelt.

    Kann man sich die Patches eigentlich noch nachträglich auftreiben, falls sie nicht alle automatisch installiert werden sollten?

    Das könnte nämlich auch der Fall sein, warum einiges nicht vom CM installiert wird.

  • Tane kannst du ganz einfach neu installieren,in dem du als

    registrierter User auf My Trainz gehst und dort links auf " Download T:ANE" klickst.

    Dann öffnet sich unten stehendes Fenster und du kannst die neueste Version inkl. Service Pack 2

    runterladen.Das nachträgliche Patchen entfällt also.

    Achte nur auf die korrekte Vorgehensweise der Installation.(Daten und Contentordner getrennt,sowie der Aufbau der Datenbank)

    Ich weiß im Moment nicht mehr die genaue Vorgehensweise.

    Jedenfalls wenn alles korrekt installiert und eingestellt ist,kannst du hinterher einen eventuell gespeicherten Ordner "Lokal" einfach austauschen und hast dann deinen alten Content und gespeicherte Ruten wieder.

    Deshalb,immer in regelmäßigen Abständen den Ordner "Lokal" extra abspeichern.

    Gruß

    beko

  • Dem einen Muck seine Webseite

    Mitbegründer und Vorsitzender des VzbuuuA, kurz VzbuA,

    Verein zur Bekämpfung unsinniger und unnötiger Abkürzungen.

    ___________________________________________________________________

    Windows 10 Enterprize Version 1709, 64 Bit

    Motherboard: ASUS M5A97 EVO R2.0

    CPU: AMD FX 8350 Eight-Core Prozessor 4,00 GHz

    RAM: 64 GB DDR3

    Grafikkarte: Sapphire Radeon RX470 8GB

  • 5. TANE starten, aber im Launcher-Fenster nicht auf "Start Trainz" klicken, sondern zuerst die Datenbank neu aufbauen - Menü Developer, Rebuild Database
    6. Wenn der Datenbank-Rebuild fertig ist, alle fenster schließen und TANE beenden.
    7. TANE erneut starten - nun sollte alles nomal funktionieren.

    So,gehst du vor wenn du Tane installiert hast.


    Ich werde Höchstwahrscheinlich meine TANE CD zum Installieren benutzen, da kenne ich immerhin die Vorgehensweise.

    Warum die CD?

    Lade es von My Trainz runter,dann hast auch gleichzeitig das Service Pack 2 mit drinnen.

    Vorgehensweise ist wie zuvor beschrieben.

  • Hast du nun eine Seriennummer oder nicht? Wenn ja und die ist registriert, dann geht das.

    Dem einen Muck seine Webseite

    Mitbegründer und Vorsitzender des VzbuuuA, kurz VzbuA,

    Verein zur Bekämpfung unsinniger und unnötiger Abkürzungen.

    ___________________________________________________________________

    Windows 10 Enterprize Version 1709, 64 Bit

    Motherboard: ASUS M5A97 EVO R2.0

    CPU: AMD FX 8350 Eight-Core Prozessor 4,00 GHz

    RAM: 64 GB DDR3

    Grafikkarte: Sapphire Radeon RX470 8GB

  • Wenn ich das Spiel mit der CD installiere habe ich eine Seriennummer, die der CD.

    Aber wenn ich TANE aus dem Internet hole doch nicht.

    Das war meine alte Ansicht, nun sehe ich aber, dass die CD der Schlüssel zum Internet-Download ist und darum die Seriennummer der CD selbst immernoch mit diesem Download zusammenhängt.

    Ich dachte CD und Internet-Download wären zwei völlig unterschiedliche Welten, die keinerlei Zusammenhänge aufweisen.

    Tut mir leid, ich wusste noch nicht, dass die Lizenz dort schon drinn steckt und dass der Download aus dem Internet so mit der CD zusammenhängt.


    Das ändert natürlich so einiges, ich hole es mir höchstwahrscheinlich doch aus dem Internet.

  • Ich habe heute mit der Deinstallation von TANE angefangen, sie verlief problemlos, aber leider nicht die von TS12.

    Wenn ich TS12 deinstallieren möchte, tritt ein Fehler auf.

    "Bei der Deinstallation von Trainz Simulator 12 ist ein Fehler aufgetreten, möglicherweise wurde es bereits deinstalliert.

    Möchten Sie Trainz Simulator 12 von Programme und Funktionen löschen?"

    Diese Meldung mit ungefähr diesem Text erscheint dann immer, dabei ist TS12 noch installiert, weil ich es immernoch starten und spielen kann.

    Sollte ich es in diesem Fall einfach nur löschen, oder könnten noch unerwünschte Dateien drüber bleiben, wenn ich es nicht fachgerecht deinstallieren kann?




    Welche Version sollte ich überhaupt nehmen, wenn ich TANE von My Trainz installiere, US, UK, oder vielleicht den Online Installer?

    Bestimmt den Online Installer, weil dort, soviel ich dem englischen Text darüber entnehmen kann, alles gleich mitinstalliert wird, liege ich damit richtig?