Die Bogeys . Ich bekomme es nicht hin.

From now, the TrainzDepot is in a read-only mode, see our announcement). From now, our new place-to-go, https://www.trainz.de is available.
Since 28.02.2019 personal data (e.g. profile contents, private messagers) has been deleted.
  • Augenscheinlich bin ich mal wieder zu blöd. :(

    Ich habe folgendes Objekt erstellt :




    Einen Torpedowagen , welcher 4 getrennte Bogeys erhalten soll.

    Ich habe 2 verschiedene Bogeys erstellt.

    Eines mit vier und eines mit fünf Achsen.

    Die Punkte sind an den markierten Stellen im MAX eingetragen.

    Sie finden sich auch in der IM-File wieder.




    Leider bekomme ich immer eine Fehlermeldung (missing_bogeys) :



    Meine Config sieht so aus :



    Komischerweise wird allerdings ein Bogey im Spiel angezeigt.

    Nämlich jenes , was unter a.bog0 erscheinen soll.


    Was habe ich denn jetzt wieder alles falsch gemacht ?

    Kann mir bitte jemand behilflich sein ?

  • Du fängst in Fahrtrichtung (front) mit a.bog0 an.

    Am Hinterteil kommt a.bog 1.

    dazwischen hinter a.bog0 dann fortlaufend die anderen Bogeys...


    Also in der Ansicht von oben:


    unten a.bog0 a.bog2 a.bog3 usw. a.bog1


    Zudem muss eines der 5-achsigen Bogeys gedreht werden.

    Entweder a.bog0 oder a.bog1, jenachdem, wie rum Du das in Fahrtrichtung gebaut hast.


    In den alten Trainzversionen mit -a.bogx


    Heute wohl mit einer 1 bei "reverset"...?


    Jörg

  • unten a.bog0 a.bog2 a.bog3 usw. a.bog1


    Zudem muss eines der 5-achsigen Bogeys gedreht werden.

    Entweder a.bog0 oder a.bog1, jenachdem, wie rum Du das in Fahrtrichtung gebaut hast.


    In den alten Trainzversionen mit -a.bogx


    Heute wohl mit einer 1 bei "reverset"...?

    Hi Joerg

    Ich habe es probiert, wie du geraten hattest. ( bog0 , bog2 , bog3 , bog1)

    Bog1 = reversed 1

    Leider ohne Erfolg.

    Ich bekomme immer die Fehlermeldung "VE 212". ( missing bogeys )

    Sollte das evtl. an meinen Bogeys liegen ?

  • Nein , das ist es auch nicht.

    Ich habe jetzt 4 fremde , unterschiedliche Bogeys genommen.

    Das Resultat ""VE 212". ( missing bogeys )" ist das selbe !

    Müssen die a.bogxx mit dem Hauptmesh verlinkt werden ?

    Das wäre mir allerdings neu.


    Ich habe nun alle a.bogxx gelöscht und neu gesetzt.

    Danach erhielt ich keine Fehlermeldung mehr und es sah endlich so aus , wie ich es erhofft hatte.

    Die Freude hielt nicht lange an.

    Sobald ich das Ding drehen oder bewegen will, kommt dieses haessliche Kreuz.



    Was nun ??

  • Fehler gefunden :

    Ich habe mich erinnert , was unser Freund Hadotwe mal geschrieben hat :

    'a.bog0' oder auch 'a.limfront' müssen im -(minus) y-Bereich liegen.

    Das hatte ich leider vergessen.

    limfront war richtig , a.bog0 war falsch gesetzt.

    bog 0 und bog 1 verschoben , und alles ist gut.


    Netter Gruss

    Tilo


    p.s. : Schade dass es dazu keine Fehlermeldung gab.

  • 'a.bog0' oder auch 'a.limfront' müssen im -(minus) y-Bereich liegen.

    ...aus diesem Grund die attachments, z.b. a.bogxx immer in der Draufsicht setzen!

    Hierbei passt zum einen die Ausrichtung der Punte und eben zum anderen, dass die Front unten in -y Richtung liegt...

  • .aus diesem Grund die attachments, z.b. a.bogxx immer in der Draufsicht setzen!

    Das hatte ich auch. Allerdings hatte ich im Kopf vorn und hinten vertauscht.

    Blöder Fehler. Na , ich werde halt DOCH älter. ;(

  • Heute wohl mit einer 1 bei "reverset"...?


    Jörg

    Stimmt Jörg. so sollte es sein. Auch laut WIKI.

    Leider funktioniert es nicht.

    Gleichgültig ob REVERSED = 0 oder = 1. Es ändert sich nichts.

    Ich habe dann a.bog1 um 180 Grad gedreht.

    Nur so geht es.

    Sehr merkwürdig.


    Und

    rotation-permitted 1

    sideplay-permitted 1

    ist nötig bei einer Wagenlänge von ca. 30 Metern.

    Kleine Radien darf man dann nicht befahren.

    Aber das versteht sich ja von selbst.


    Schönen Feiertag wünsche ich noch

    Gruss

    Tilo

  • Der Eintrag 'reversed 1' ändert nicht die Position des Bogeys sondern die Richtung der Animation, damit die Räder sich immer in Fahrtrichtung drehen.


    Peter

  • Der Eintrag 'reversed 1' ändert nicht die Position des Bogeys sondern die Richtung der Animation, damit die Räder sich immer in Fahrtrichtung drehen.


    Peter

    Danke Peter , wieder etwas dazu gelernt.

    Wenn sie denn animiert wären , dann müsste ich also mit "reversed" und der Drehung des "a.bogxx" experimentieren.

    Richtig ?


    Tilo